27.1 openai configure

20231126

The openai package is Python based and utilises the ffmpeg system application. To ensure the dependencies are installed run the configure command:

ml configure openai

The configuration will proceed with something like the following:

*** The following required system packages are already installed:
  ffmpeg

*** The following required pip packages are already installed:
  openai-whisper

*** Downloading required files ...

Configuring using '/home/gjw/.mlhub/openai/configure.sh'...

No configure required just yet.

To view the model's README:

  $ ml readme openai

Python and support files are downloaded from GitHub as specified in the MLHUB.yaml file.

meta:
  name         : openai
  title        : Open AI packages, including whisper for speech transcription
  keywords     : python, speech, transcription
  version      : 0.0.1
  languages    : py
  license      : gpl3
  author       : Graham.Williams@togaware.com
  url          : https://github.com/gjwgit/openai
dependencies:
  system:
    - ffmpeg
  pip3:
    - openai-whisper
  files:
    - README.md
    - transcribe.py
    - configure.sh
commands:
  transcribe : Convert an audio file into text.


Your donation will support ongoing availability and give you access to the PDF version of this book. Desktop Survival Guides include Data Science, GNU/Linux, and MLHub. Books available on Amazon include Data Mining with Rattle and Essentials of Data Science. Popular open source software includes rattle, wajig, and mlhub. Hosted by Togaware, a pioneer of free and open source software since 1984. Copyright © 1995-2022 Graham.Williams@togaware.com Creative Commons Attribution-ShareAlike 4.0